summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/graphicsview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/graphicsview/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/graphicsview/CMakeLists.txt23
1 files changed, 5 insertions, 18 deletions
diff --git a/tests/auto/widgets/graphicsview/CMakeLists.txt b/tests/auto/widgets/graphicsview/CMakeLists.txt
index 5e6fddccce..b0ea73b65e 100644
--- a/tests/auto/widgets/graphicsview/CMakeLists.txt
+++ b/tests/auto/widgets/graphicsview/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from graphicsview.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
if(QT_FEATURE_private_tests)
add_subdirectory(qgraphicsanchorlayout)
@@ -17,20 +18,6 @@ add_subdirectory(qgraphicsobject)
add_subdirectory(qgraphicspixmapitem)
add_subdirectory(qgraphicspolygonitem)
add_subdirectory(qgraphicstransform)
-if(QT_FEATURE_style_fusion)
- # special case begin
- # These tests are never run in coin with qmake since the statement
- # !qtConfig(style-fusion): always passes causing the subdirs to be removed.
- # For these tests to be generated the .pro file needs to be patched and
- # the above line changed to !qtConfig(style-fusion). That being said,
- # one of the test fails and needs to be corrected by someone with know how in
- # that area. Until then we will disable them to mimic the behavior seen in
- # coin.
- #add_subdirectory(qgraphicsproxywidget)
- #add_subdirectory(qgraphicswidget)
- # special case end
-endif()
-# QTBUG-87671 # special case
-if(NOT ANDROID)
- add_subdirectory(qgraphicsview)
-endif()
+add_subdirectory(qgraphicsproxywidget)
+add_subdirectory(qgraphicswidget)
+add_subdirectory(qgraphicsview)