summaryrefslogtreecommitdiffstats
path: root/tests/auto/xml/dom/qdom/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/xml/dom/qdom/CMakeLists.txt')
-rw-r--r--tests/auto/xml/dom/qdom/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/auto/xml/dom/qdom/CMakeLists.txt b/tests/auto/xml/dom/qdom/CMakeLists.txt
index d72ef57332..4eea988cc3 100644
--- a/tests/auto/xml/dom/qdom/CMakeLists.txt
+++ b/tests/auto/xml/dom/qdom/CMakeLists.txt
@@ -1,9 +1,16 @@
-# Generated from qdom.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qdom Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdom LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
@@ -15,7 +22,8 @@ list(APPEND test_data "umlaut.xml")
qt_internal_add_test(tst_qdom
SOURCES
tst_qdom.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Xml
+ Qt::XmlPrivate
TESTDATA ${test_data}
)