summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/corelib/thread/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/benchmarks/corelib/thread/CMakeLists.txt')
-rw-r--r--tests/benchmarks/corelib/thread/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/benchmarks/corelib/thread/CMakeLists.txt b/tests/benchmarks/corelib/thread/CMakeLists.txt
index 107380802c..fd7cbe6117 100644
--- a/tests/benchmarks/corelib/thread/CMakeLists.txt
+++ b/tests/benchmarks/corelib/thread/CMakeLists.txt
@@ -1,9 +1,9 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from thread.pro.
-
-add_subdirectory(qfuture)
+if(QT_FEATURE_future)
+ add_subdirectory(qfuture)
+endif()
add_subdirectory(qmutex)
add_subdirectory(qreadwritelock)
add_subdirectory(qthreadstorage)