summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/corelib/tools/qhash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/benchmarks/corelib/tools/qhash/CMakeLists.txt')
-rw-r--r--tests/benchmarks/corelib/tools/qhash/CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/tests/benchmarks/corelib/tools/qhash/CMakeLists.txt b/tests/benchmarks/corelib/tools/qhash/CMakeLists.txt
index 760b1848d7..9002cc0723 100644
--- a/tests/benchmarks/corelib/tools/qhash/CMakeLists.txt
+++ b/tests/benchmarks/corelib/tools/qhash/CMakeLists.txt
@@ -1,15 +1,18 @@
-# Generated from qhash.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
-## tst_hash Binary:
+## tst_bench_qhash Binary:
#####################################################################
-qt_add_benchmark(tst_hash
+qt_internal_add_benchmark(tst_bench_qhash
SOURCES
- main.cpp
+ tst_bench_qhash.cpp
outofline.cpp
+ NO_PCH_SOURCES
+ tst_bench_qhash.cpp # undef QT_NO_FOREACH
INCLUDE_DIRECTORIES
.
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Test
)