summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt')
-rw-r--r--tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt23
1 files changed, 10 insertions, 13 deletions
diff --git a/tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt b/tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt
index 3bdb724fae..c7b18103a5 100644
--- a/tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt
+++ b/tests/benchmarks/widgets/graphicsview/functional/GraphicsViewBenchmark/CMakeLists.txt
@@ -1,10 +1,11 @@
-# Generated from GraphicsViewBenchmark.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_GraphicsViewBenchmark Binary:
#####################################################################
-qt_add_benchmark(tst_GraphicsViewBenchmark
+qt_internal_add_benchmark(tst_GraphicsViewBenchmark
SOURCES
main.cpp
widgets/abstractitemcontainer.cpp widgets/abstractitemcontainer.h
@@ -38,7 +39,7 @@ qt_add_benchmark(tst_GraphicsViewBenchmark
widgets/topbar.cpp widgets/topbar.h
INCLUDE_DIRECTORIES
widgets
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
Qt::Svg
Qt::Test
@@ -124,7 +125,7 @@ set(GraphicsViewBenchmark_resource_files
"resources/blue_SVG/blue_user_status_online_38x38px.svg"
)
-qt_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark"
+qt_internal_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark"
PREFIX
"/themes/blue"
FILES
@@ -213,7 +214,7 @@ set(GraphicsViewBenchmark1_resource_files
"resources/lime_SVG/lime_user_status_online_24x24px.svg"
)
-qt_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark1"
+qt_internal_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark1"
PREFIX
"/themes/lime"
FILES
@@ -322,7 +323,7 @@ set(GraphicsViewBenchmark2_resource_files
"resources/avatars/avatar_woman_010_58x58.png"
)
-qt_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark2"
+qt_internal_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark2"
PREFIX
"/avatars"
FILES
@@ -347,22 +348,18 @@ set(GraphicsViewBenchmark3_resource_files
"resources/contacts/lastnames.txt"
)
-qt_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark3"
+qt_internal_add_resource(tst_GraphicsViewBenchmark "GraphicsViewBenchmark3"
PREFIX
"/contact"
FILES
${GraphicsViewBenchmark3_resource_files}
)
-
-#### Keys ignored in scope 1:.:.:GraphicsViewBenchmark.pro:<TRUE>:
-# TEMPLATE = "app"
-
## Scopes:
#####################################################################
-qt_extend_target(tst_GraphicsViewBenchmark CONDITION TARGET Qt::OpenGL
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_GraphicsViewBenchmark CONDITION TARGET Qt::OpenGL
+ LIBRARIES
Qt::OpenGL
Qt::OpenGLWidgets
)