summaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt')
-rw-r--r--tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt20
1 files changed, 7 insertions, 13 deletions
diff --git a/tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt b/tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt
index ae5a17f020..e3577fd91e 100644
--- a/tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt
+++ b/tests/benchmarks/widgets/graphicsview/qgraphicsview/benchapps/chipTest/CMakeLists.txt
@@ -1,17 +1,18 @@
-# Generated from chip.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## chip Binary:
#####################################################################
-qt_add_benchmark(chip
+qt_internal_add_benchmark(chip
GUI
SOURCES
chip.cpp chip.h
main.cpp
mainwindow.cpp mainwindow.h
view.cpp view.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
)
@@ -25,24 +26,17 @@ set(images_resource_files
"zoomout.png"
)
-qt_add_resource(chip "images"
+qt_internal_add_resource(chip "images"
PREFIX
"/"
FILES
${images_resource_files}
)
-
-#### Keys ignored in scope 1:.:.:chip.pro:<TRUE>:
-# INSTALLS = "target" "sources"
-# sources.files = "$$SOURCES" "$$HEADERS" "$$RESOURCES" "*.png" "*.pro" "*.html" "*.doc" "images"
-# sources.path = "$$[QT_INSTALL_EXAMPLES]/graphicsview/chip"
-# target.path = "$$[QT_INSTALL_EXAMPLES]/graphicsview/chip"
-
## Scopes:
#####################################################################
-qt_extend_target(chip CONDITION TARGET Qt::OpenGL
- PUBLIC_LIBRARIES
+qt_internal_extend_target(chip CONDITION TARGET Qt::OpenGL
+ LIBRARIES
Qt::OpenGL
)