summaryrefslogtreecommitdiffstats
path: root/tests/manual/android_content_uri/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/android_content_uri/CMakeLists.txt')
-rw-r--r--tests/manual/android_content_uri/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/manual/android_content_uri/CMakeLists.txt b/tests/manual/android_content_uri/CMakeLists.txt
index a8a815fd94..368e023ba6 100644
--- a/tests/manual/android_content_uri/CMakeLists.txt
+++ b/tests/manual/android_content_uri/CMakeLists.txt
@@ -1,3 +1,11 @@
+# Copyright (C) 2024 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(android_content_uri LANGUAGES CXX)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_content_uris
SOURCES
tst_content_uris.cpp