summaryrefslogtreecommitdiffstats
path: root/tests/manual/cocoa/menurama/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/cocoa/menurama/CMakeLists.txt')
-rw-r--r--tests/manual/cocoa/menurama/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/manual/cocoa/menurama/CMakeLists.txt b/tests/manual/cocoa/menurama/CMakeLists.txt
new file mode 100644
index 0000000000..3519fadcf9
--- /dev/null
+++ b/tests/manual/cocoa/menurama/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## Menurama Binary:
+#####################################################################
+
+qt_internal_add_manual_test(Menurama
+ GUI
+ SOURCES
+ main.cpp
+ mainwindow.cpp mainwindow.h mainwindow.ui
+ menuramaapplication.cpp menuramaapplication.h
+ NO_PCH_SOURCES
+ menuramaapplication.cpp # undef QT_NO_FOREACH
+ LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+ ENABLE_AUTOGEN_TOOLS
+ uic
+)