summaryrefslogtreecommitdiffstats
path: root/tests/manual/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt')
-rw-r--r--tests/manual/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/manual/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt b/tests/manual/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
new file mode 100644
index 0000000000..26978a901d
--- /dev/null
+++ b/tests/manual/examples/widgets/layouts/dynamiclayouts/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(dynamiclayouts LANGUAGES CXX)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/layouts/dynamiclayouts")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
+qt_standard_project_setup()
+
+qt_add_executable(dynamiclayouts
+ dialog.cpp dialog.h
+ main.cpp
+)
+
+set_target_properties(dynamiclayouts PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(dynamiclayouts PRIVATE
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Widgets
+)
+
+install(TARGETS dynamiclayouts
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)