summaryrefslogtreecommitdiffstats
path: root/tests/manual/examples/widgets/tools/plugandpaint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/examples/widgets/tools/plugandpaint/CMakeLists.txt')
-rw-r--r--tests/manual/examples/widgets/tools/plugandpaint/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/manual/examples/widgets/tools/plugandpaint/CMakeLists.txt b/tests/manual/examples/widgets/tools/plugandpaint/CMakeLists.txt
new file mode 100644
index 0000000000..16b261f2f1
--- /dev/null
+++ b/tests/manual/examples/widgets/tools/plugandpaint/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(plugandpaint LANGUAGES CXX)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tools/plugandpaint")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
+qt_standard_project_setup()
+
+add_subdirectory(plugins)
+add_subdirectory(app)