summaryrefslogtreecommitdiffstats
path: root/tests/manual/examples/widgets/touch/fingerpaint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/examples/widgets/touch/fingerpaint/CMakeLists.txt')
-rw-r--r--tests/manual/examples/widgets/touch/fingerpaint/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/manual/examples/widgets/touch/fingerpaint/CMakeLists.txt b/tests/manual/examples/widgets/touch/fingerpaint/CMakeLists.txt
new file mode 100644
index 0000000000..c06a91b53b
--- /dev/null
+++ b/tests/manual/examples/widgets/touch/fingerpaint/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(fingerpaint LANGUAGES CXX)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/touch/fingerpaint")
+
+find_package(Qt6
+ REQUIRED COMPONENTS Core Gui Widgets
+ OPTIONAL_COMPONENTS PrintSupport
+)
+
+qt_standard_project_setup()
+
+qt_add_executable(fingerpaint
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ scribblearea.cpp scribblearea.h
+)
+
+set_target_properties(fingerpaint PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(fingerpaint PRIVATE
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Widgets
+)
+
+if (TARGET Qt6::PrintSupport)
+ target_link_libraries(fingerpaint PRIVATE Qt6::PrintSupport)
+endif()
+
+install(TARGETS fingerpaint
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)