summaryrefslogtreecommitdiffstats
path: root/tests/manual/highdpi/screengadget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/highdpi/screengadget/CMakeLists.txt')
-rw-r--r--tests/manual/highdpi/screengadget/CMakeLists.txt31
1 files changed, 12 insertions, 19 deletions
diff --git a/tests/manual/highdpi/screengadget/CMakeLists.txt b/tests/manual/highdpi/screengadget/CMakeLists.txt
index 030f8daa7c..d9045541bb 100644
--- a/tests/manual/highdpi/screengadget/CMakeLists.txt
+++ b/tests/manual/highdpi/screengadget/CMakeLists.txt
@@ -1,21 +1,14 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR GPL-3.0-only WITH Qt-GPL-exception-1.0
-# special case skip regeneration
-cmake_minimum_required(VERSION 3.16)
-project(screengadget LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_add_executable(screengadget
- main.cpp
+#####################################################################
+## screengadget Binary:
+#####################################################################
+
+qt_internal_add_manual_test(screengadget
+ GUI
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+ Qt::GuiPrivate
)
-
-target_link_libraries(screengadget PUBLIC
- Qt::Core
- Qt::Gui
- Qt::GuiPrivate
- Qt::Widgets
-)
-