summaryrefslogtreecommitdiffstats
path: root/tests/manual/inputdevices/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/inputdevices/CMakeLists.txt')
-rw-r--r--tests/manual/inputdevices/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/manual/inputdevices/CMakeLists.txt b/tests/manual/inputdevices/CMakeLists.txt
new file mode 100644
index 0000000000..54dd2556fb
--- /dev/null
+++ b/tests/manual/inputdevices/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Copyright (C) 2024 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+project(inputdevices)
+cmake_minimum_required(VERSION 3.19)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
+qt_add_executable(inputdevices
+ main.cpp
+ inputdevicemodel.h inputdevicemodel.cpp
+)
+
+set_target_properties(inputdevices PROPERTIES
+ AUTOMOC TRUE
+)
+
+target_link_libraries(inputdevices PUBLIC
+ Qt::Widgets
+)