summaryrefslogtreecommitdiffstats
path: root/tests/manual/qlocale/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qlocale/CMakeLists.txt')
-rw-r--r--tests/manual/qlocale/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/manual/qlocale/CMakeLists.txt b/tests/manual/qlocale/CMakeLists.txt
index c837bf5a9b..e749565129 100644
--- a/tests/manual/qlocale/CMakeLists.txt
+++ b/tests/manual/qlocale/CMakeLists.txt
@@ -1,10 +1,11 @@
-# Generated from qlocale.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## qlocale Binary:
#####################################################################
-qt_add_manual_test(qlocale
+qt_internal_add_manual_test(qlocale
GUI
SOURCES
calendar.cpp calendar.h
@@ -16,7 +17,9 @@ qt_add_manual_test(qlocale
miscellaneous.cpp miscellaneous.h
numberformats.cpp numberformats.h
window.cpp window.h
- PUBLIC_LIBRARIES
+ NO_PCH_SOURCES
+ languages.cpp # undef QT_NO_FOREACH
+ LIBRARIES
Qt::Gui
Qt::Widgets
)