summaryrefslogtreecommitdiffstats
path: root/tests/manual/qnetworkinformation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qnetworkinformation/CMakeLists.txt')
-rw-r--r--tests/manual/qnetworkinformation/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/manual/qnetworkinformation/CMakeLists.txt b/tests/manual/qnetworkinformation/CMakeLists.txt
new file mode 100644
index 0000000000..3456c350a2
--- /dev/null
+++ b/tests/manual/qnetworkinformation/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(qnetworkinformation
+ SOURCES
+ tst_qnetworkinformation.cpp
+ LIBRARIES
+ Qt::Network
+ Qt::Test
+)
+
+qt_internal_extend_target(qnetworkinformation CONDITION ANDROID OR UIKIT
+ SOURCES
+ mainwindow.h
+ LIBRARIES
+ Qt::Widgets
+ DEFINES
+ MOBILE)