summaryrefslogtreecommitdiffstats
path: root/tests/manual/qopenglwidget/dockedopenglwidget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qopenglwidget/dockedopenglwidget/CMakeLists.txt')
-rw-r--r--tests/manual/qopenglwidget/dockedopenglwidget/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/manual/qopenglwidget/dockedopenglwidget/CMakeLists.txt b/tests/manual/qopenglwidget/dockedopenglwidget/CMakeLists.txt
new file mode 100644
index 0000000000..e34342fc37
--- /dev/null
+++ b/tests/manual/qopenglwidget/dockedopenglwidget/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+set(CMAKE_AUTOUIC ON)
+
+qt_internal_add_manual_test(dockedopenglwidget
+ GUI
+ SOURCES
+ main.cpp
+ geometryengine.cpp geometryengine.h
+ mainwidget.cpp mainwidget.h
+ mainwindow.cpp mainwindow.h
+ mainwindow.ui
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::OpenGL
+ Qt::OpenGLWidgets
+ Qt::Widgets
+ Qt::WidgetsPrivate
+)
+
+qt_add_resources(dockedopenglwidget "dockedopenglwidget"
+ PREFIX
+ "/"
+ FILES
+ vshader.glsl
+ fshader.glsl
+ cube.png
+)