summaryrefslogtreecommitdiffstats
path: root/tests/manual/qopenglwidget/openglwidget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qopenglwidget/openglwidget/CMakeLists.txt')
-rw-r--r--tests/manual/qopenglwidget/openglwidget/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/manual/qopenglwidget/openglwidget/CMakeLists.txt b/tests/manual/qopenglwidget/openglwidget/CMakeLists.txt
new file mode 100644
index 0000000000..967feda558
--- /dev/null
+++ b/tests/manual/qopenglwidget/openglwidget/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## openglwidget Binary:
+#####################################################################
+
+qt_internal_add_manual_test(openglwidget
+ GUI
+ SOURCES
+ main.cpp
+ openglwidget.cpp openglwidget.h
+ NO_PCH_SOURCES
+ main.cpp # undef QT_NO_FOREACH
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::OpenGL
+ Qt::OpenGLWidgets
+ Qt::Widgets
+ Qt::WidgetsPrivate
+)