summaryrefslogtreecommitdiffstats
path: root/tests/manual/qtabletevent/device_information/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qtabletevent/device_information/CMakeLists.txt')
-rw-r--r--tests/manual/qtabletevent/device_information/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/manual/qtabletevent/device_information/CMakeLists.txt b/tests/manual/qtabletevent/device_information/CMakeLists.txt
new file mode 100644
index 0000000000..a0583b1f93
--- /dev/null
+++ b/tests/manual/qtabletevent/device_information/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+project(tablet_device_info)
+cmake_minimum_required(VERSION 3.19)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
+qt_add_executable(tablet_device_info
+ main.cpp
+ tabletwidget.h tabletwidget.cpp
+)
+
+set_target_properties(tablet_device_info PROPERTIES
+ AUTOMOC TRUE
+)
+
+target_link_libraries(tablet_device_info PUBLIC
+ Qt::Widgets
+)