summaryrefslogtreecommitdiffstats
path: root/tests/manual/qtabletevent/device_information/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qtabletevent/device_information/CMakeLists.txt')
-rw-r--r--tests/manual/qtabletevent/device_information/CMakeLists.txt28
1 files changed, 15 insertions, 13 deletions
diff --git a/tests/manual/qtabletevent/device_information/CMakeLists.txt b/tests/manual/qtabletevent/device_information/CMakeLists.txt
index a9c4fae8af..a0583b1f93 100644
--- a/tests/manual/qtabletevent/device_information/CMakeLists.txt
+++ b/tests/manual/qtabletevent/device_information/CMakeLists.txt
@@ -1,18 +1,20 @@
-# Copyright (C) 2022 The Qt Company Ltd.
+# Copyright (C) 2023 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from device_information.pro.
+project(tablet_device_info)
+cmake_minimum_required(VERSION 3.19)
-#####################################################################
-## device_information Binary:
-#####################################################################
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-qt_internal_add_manual_test(device_information
- GUI
- SOURCES
- main.cpp
- tabletwidget.cpp tabletwidget.h
- LIBRARIES
- Qt::Gui
- Qt::Widgets
+qt_add_executable(tablet_device_info
+ main.cpp
+ tabletwidget.h tabletwidget.cpp
+)
+
+set_target_properties(tablet_device_info PROPERTIES
+ AUTOMOC TRUE
+)
+
+target_link_libraries(tablet_device_info PUBLIC
+ Qt::Widgets
)