summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/tessellation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/tessellation/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/tessellation/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/manual/rhi/tessellation/CMakeLists.txt b/tests/manual/rhi/tessellation/CMakeLists.txt
new file mode 100644
index 0000000000..bdb3d8d2f7
--- /dev/null
+++ b/tests/manual/rhi/tessellation/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(tessellation
+ GUI
+ SOURCES
+ tessellation.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)
+
+set(tessellation_resource_files
+ "test.vert.qsb"
+ "test.tesc.qsb"
+ "test.tese.qsb"
+ "test.frag.qsb"
+)
+
+qt_internal_add_resource(tessellation "tessellation"
+ PREFIX
+ "/"
+ FILES
+ ${tessellation_resource_files}
+)