summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/tex1d/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/tex1d/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/tex1d/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/manual/rhi/tex1d/CMakeLists.txt b/tests/manual/rhi/tex1d/CMakeLists.txt
new file mode 100644
index 0000000000..f456b35d56
--- /dev/null
+++ b/tests/manual/rhi/tex1d/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(tex1d
+ GUI
+ SOURCES
+ tex1d.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)
+
+set(tex1d_resource_files
+ "texture1d.vert.qsb"
+ "texture1d.frag.qsb"
+)
+
+qt_internal_add_resource(tex1d "tex1d"
+ PREFIX
+ "/"
+ FILES
+ ${tex1d_resource_files}
+)