summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/tex3d/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/tex3d/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/tex3d/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/manual/rhi/tex3d/CMakeLists.txt b/tests/manual/rhi/tex3d/CMakeLists.txt
new file mode 100644
index 0000000000..8b2ac292cf
--- /dev/null
+++ b/tests/manual/rhi/tex3d/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(tex3d
+ GUI
+ SOURCES
+ tex3d.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)
+
+set(tex3d_resource_files
+ "texture3d.vert.qsb"
+ "texture3d.frag.qsb"
+)
+
+qt_internal_add_resource(tex3d "tex3d"
+ PREFIX
+ "/"
+ FILES
+ ${tex3d_resource_files}
+)