summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/clipboard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/wasm/clipboard/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/clipboard/CMakeLists.txt18
1 files changed, 6 insertions, 12 deletions
diff --git a/tests/manual/wasm/clipboard/CMakeLists.txt b/tests/manual/wasm/clipboard/CMakeLists.txt
index 4bc60a5edc..40fb8ca308 100644
--- a/tests/manual/wasm/clipboard/CMakeLists.txt
+++ b/tests/manual/wasm/clipboard/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from clipboard.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## clipboard Binary:
@@ -9,7 +10,9 @@ qt_internal_add_manual_test(clipboard
SOURCES
main.cpp
mainwindow.cpp mainwindow.h mainwindow.ui
- PUBLIC_LIBRARIES
+ NO_PCH_SOURCES
+ main.cpp # undef QT_NO_FOREACH
+ LIBRARIES
Qt::Core
Qt::Gui
Qt::Widgets
@@ -32,15 +35,6 @@ qt_internal_add_resource(clipboard "data"
#####################################################################
qt_internal_extend_target(clipboard CONDITION (QT_MAJOR_VERSION GREATER 4)
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Widgets
)
-
-#### Keys ignored in scope 3:.:.:clipboard.pro:QNX:
-# target.path = "/tmp/$${TARGET}/bin"
-
-#### Keys ignored in scope 5:.:.:clipboard.pro:UNIX AND NOT ANDROID:
-# target.path = "/opt/$${TARGET}/bin"
-
-#### Keys ignored in scope 6:.:.:clipboard.pro:NOT target.path_ISEMPTY:
-# INSTALLS = "target"