summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt b/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
index 09b5cdb1e9..fe7cfb9030 100644
--- a/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
+++ b/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
@@ -1,6 +1,12 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
qt_internal_add_manual_test(asyncify_exec
SOURCES
main.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
)
+
+# Enable asyncify for this test. Also enable optimizations in order to reduce the binary size.
+target_link_options(asyncify_exec PUBLIC -sASYNCIFY -Os)