summaryrefslogtreecommitdiffstats
path: root/tests/manual/xembed/gtk-container/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/xembed/gtk-container/CMakeLists.txt')
-rw-r--r--tests/manual/xembed/gtk-container/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/manual/xembed/gtk-container/CMakeLists.txt b/tests/manual/xembed/gtk-container/CMakeLists.txt
new file mode 100644
index 0000000000..c109bbc95b
--- /dev/null
+++ b/tests/manual/xembed/gtk-container/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+qt_find_package(GTK3)
+qt_find_package(X11)
+
+#####################################################################
+## gtk-container Binary:
+#####################################################################
+
+qt_internal_add_manual_test(gtk-container
+ GUI
+ SOURCES
+ gtk-container.cpp
+ DEFINES
+ GDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_6
+ LIBRARIES
+ PkgConfig::GTK3
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ X11::X11
+)