summaryrefslogtreecommitdiffstats
path: root/tests/manual/xmlstreamlint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/xmlstreamlint/CMakeLists.txt')
-rw-r--r--tests/manual/xmlstreamlint/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/manual/xmlstreamlint/CMakeLists.txt b/tests/manual/xmlstreamlint/CMakeLists.txt
new file mode 100644
index 0000000000..5b11c9035d
--- /dev/null
+++ b/tests/manual/xmlstreamlint/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(xmlstreamlint LANGUAGES CXX)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+ endif()
+
+qt_internal_add_manual_test(xmlstreamlint
+ SOURCES
+ main.cpp
+)
+
+set_target_properties(xmlstreamlint PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ MACOSX_BUNDLE FALSE
+)
+
+target_link_libraries(xmlstreamlint PRIVATE
+ Qt::Core
+ Qt::Xml
+)
+