aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qcoapclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qcoapclient/CMakeLists.txt')
-rw-r--r--tests/auto/qcoapclient/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/auto/qcoapclient/CMakeLists.txt b/tests/auto/qcoapclient/CMakeLists.txt
new file mode 100644
index 0000000..7e92725
--- /dev/null
+++ b/tests/auto/qcoapclient/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Generated from qcoapclient.pro.
+
+#####################################################################
+## qcoapclient Test:
+#####################################################################
+
+qt_add_test(qcoapclient
+ EXCEPTIONS # special case
+ GUI
+ SOURCES
+ ../coapnetworksettings.h
+ tst_qcoapclient.cpp
+ LIBRARIES
+ Qt::CoapPrivate
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Coap
+ Qt::Network
+)
+
+#### Keys ignored in scope 1:.:.:qcoapclient.pro:<TRUE>:
+# QT_TEST_SERVER_LIST = "californium" "freecoap"
+
+## Scopes:
+#####################################################################
+
+# special case begin
+qt_extend_target(qcoapclient CONDITION DEFINED ENV{COAP_TEST_SERVER_IP}
+ DEFINES
+ COAP_TEST_SERVER_IP=\\\"$ENV{COAP_TEST_SERVER_IP}\\\"
+)
+# special case end