aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qcoapqudpconnection/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qcoapqudpconnection/CMakeLists.txt')
-rw-r--r--tests/auto/qcoapqudpconnection/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/auto/qcoapqudpconnection/CMakeLists.txt b/tests/auto/qcoapqudpconnection/CMakeLists.txt
new file mode 100644
index 0000000..b415301
--- /dev/null
+++ b/tests/auto/qcoapqudpconnection/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from qcoapqudpconnection.pro.
+
+#####################################################################
+## qcoapqudpconnection Test:
+#####################################################################
+
+qt_add_test(qcoapqudpconnection
+ SOURCES
+ ../coapnetworksettings.h
+ tst_qcoapqudpconnection.cpp
+ LIBRARIES
+ Qt::CoapPrivate
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Coap
+ Qt::Network
+)
+
+#### Keys ignored in scope 1:.:.:qcoapqudpconnection.pro:<TRUE>:
+# QT_TEST_SERVER_LIST = "californium"
+
+## Scopes:
+#####################################################################
+
+# special case begin
+qt_extend_target(qcoapqudpconnection CONDITION DEFINED ENV{COAP_TEST_SERVER_IP}
+ DEFINES
+ COAP_TEST_SERVER_IP=\\\"$ENV{COAP_TEST_SERVER_IP}\\\"
+)
+# special case end