summaryrefslogtreecommitdiffstats
path: root/examples/bluetooth/btchat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/bluetooth/btchat/CMakeLists.txt')
-rw-r--r--examples/bluetooth/btchat/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/examples/bluetooth/btchat/CMakeLists.txt b/examples/bluetooth/btchat/CMakeLists.txt
index e06631d1..1cce8bf8 100644
--- a/examples/bluetooth/btchat/CMakeLists.txt
+++ b/examples/bluetooth/btchat/CMakeLists.txt
@@ -1,21 +1,16 @@
cmake_minimum_required(VERSION 3.16)
project(btchat LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/bluetooth/btchat")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Bluetooth)
-find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 REQUIRED COMPONENTS Bluetooth Core Widgets)
qt_add_executable(btchat
chat.cpp chat.h chat.ui
@@ -24,10 +19,12 @@ qt_add_executable(btchat
main.cpp
remoteselector.cpp remoteselector.h remoteselector.ui
)
+
set_target_properties(btchat PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(btchat PUBLIC
Qt::Bluetooth
Qt::Core