summaryrefslogtreecommitdiffstats
path: root/examples/nfc/ndefeditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/nfc/ndefeditor/CMakeLists.txt')
-rw-r--r--examples/nfc/ndefeditor/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/nfc/ndefeditor/CMakeLists.txt b/examples/nfc/ndefeditor/CMakeLists.txt
index 95b9e0c6..3328cd47 100644
--- a/examples/nfc/ndefeditor/CMakeLists.txt
+++ b/examples/nfc/ndefeditor/CMakeLists.txt
@@ -19,6 +19,7 @@ find_package(Qt6 COMPONENTS Nfc)
find_package(Qt6 COMPONENTS Widgets)
qt_add_executable(ndefeditor
+ MANUAL_FINALIZATION
main.cpp
mainwindow.cpp mainwindow.h mainwindow.ui
mimeimagerecordeditor.cpp mimeimagerecordeditor.h mimeimagerecordeditor.ui
@@ -36,6 +37,15 @@ target_link_libraries(ndefeditor PUBLIC
Qt::Widgets
)
+if(ANDROID)
+ set_property(TARGET ndefeditor
+ APPEND PROPERTY QT_ANDROID_PACKAGE_SOURCE_DIR
+ ${CMAKE_CURRENT_SOURCE_DIR}/android
+ )
+endif()
+
+qt_finalize_target(ndefeditor)
+
install(TARGETS ndefeditor
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"