summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 00000000..ddf3dbf6
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(QT_BUILD_STANDALONE_TESTS)
+ # Add qt_find_package calls for extra dependencies that need to be found when building
+ # the standalone tests here.
+endif()
+
+if(TARGET Qt::Bluetooth)
+ if(TARGET Qt::Quick)
+ add_subdirectory(bttestui)
+ endif()
+
+ add_subdirectory(bluetoothtestdevice)
+endif()
+
+qt_build_tests()