summaryrefslogtreecommitdiffstats
path: root/tests/auto/qbluetoothlocaldevice/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qbluetoothlocaldevice/CMakeLists.txt')
-rw-r--r--tests/auto/qbluetoothlocaldevice/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/qbluetoothlocaldevice/CMakeLists.txt b/tests/auto/qbluetoothlocaldevice/CMakeLists.txt
new file mode 100644
index 00000000..6b38e25e
--- /dev/null
+++ b/tests/auto/qbluetoothlocaldevice/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qbluetoothlocaldevice Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qbluetoothlocaldevice LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qbluetoothlocaldevice
+ SOURCES
+ tst_qbluetoothlocaldevice.cpp
+ LIBRARIES
+ Qt::BluetoothPrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_qbluetoothlocaldevice CONDITION MACOS
+ LIBRARIES
+ Qt::Widgets
+)