summaryrefslogtreecommitdiffstats
path: root/tests/auto/qbluetoothservicediscoveryagent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qbluetoothservicediscoveryagent/CMakeLists.txt')
-rw-r--r--tests/auto/qbluetoothservicediscoveryagent/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/auto/qbluetoothservicediscoveryagent/CMakeLists.txt b/tests/auto/qbluetoothservicediscoveryagent/CMakeLists.txt
new file mode 100644
index 00000000..76cd4697
--- /dev/null
+++ b/tests/auto/qbluetoothservicediscoveryagent/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qbluetoothservicediscoveryagent Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qbluetoothservicediscoveryagent LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qbluetoothservicediscoveryagent
+ SOURCES
+ tst_qbluetoothservicediscoveryagent.cpp
+ LIBRARIES
+ Qt::Bluetooth
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_qbluetoothservicediscoveryagent CONDITION MACOS
+ LIBRARIES
+ Qt::Widgets
+)
+
+set_target_properties(tst_qbluetoothservicediscoveryagent PROPERTIES
+ MACOSX_BUNDLE TRUE
+)
+
+if (APPLE AND NOT IOS)
+ # Ninja has trouble with relative paths, convert to absolute as a workaround
+ get_filename_component(SHARED_PLIST_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../shared ABSOLUTE)
+ set_target_properties(tst_qbluetoothservicediscoveryagent PROPERTIES
+ MACOSX_BUNDLE_INFO_PLIST "${SHARED_PLIST_DIR}/Info.macos.plist"
+ )
+endif()