summaryrefslogtreecommitdiffstats
path: root/tests/auto/qlowenergycontroller-gattserver/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qlowenergycontroller-gattserver/test/CMakeLists.txt')
-rw-r--r--tests/auto/qlowenergycontroller-gattserver/test/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/qlowenergycontroller-gattserver/test/CMakeLists.txt b/tests/auto/qlowenergycontroller-gattserver/test/CMakeLists.txt
new file mode 100644
index 00000000..1e01efb2
--- /dev/null
+++ b/tests/auto/qlowenergycontroller-gattserver/test/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qlowenergycontroller-gattserver Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qlowenergycontroller-gattserver LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qlowenergycontroller-gattserver
+ SOURCES
+ tst_qlowenergycontroller-gattserver.cpp
+ LIBRARIES
+ Qt::Bluetooth
+ Qt::BluetoothPrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_qlowenergycontroller-gattserver CONDITION QT_FEATURE_linux_crypto_api
+ DEFINES
+ CONFIG_LINUX_CRYPTO_API
+)
+
+qt_internal_extend_target(tst_qlowenergycontroller-gattserver CONDITION QT_FEATURE_bluez_le
+ DEFINES
+ CONFIG_BLUEZ_LE
+)
+
+qt_internal_extend_target(tst_qlowenergycontroller-gattserver CONDITION boot2qt
+ DEFINES
+ CHECK_CMAC_SUPPORT
+)