summaryrefslogtreecommitdiffstats
path: root/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt')
-rw-r--r--tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt b/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
new file mode 100644
index 00000000..b7285b3a
--- /dev/null
+++ b/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_test(q3dsurface-heightproxy_datavis
+ SOURCES
+ tst_proxy.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::DataVisualization
+)
+
+set(q3dsurface-heightproxy_resource_files
+ "customtexture.jpg"
+)
+
+qt_internal_add_resource(q3dsurface-heightproxy_datavis "q3dsurface-heightproxy"
+ PREFIX
+ "/"
+ FILES
+ ${q3dsurface-heightproxy_resource_files}
+)