summaryrefslogtreecommitdiffstats
path: root/tests/auto/qmltest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmltest/CMakeLists.txt')
-rw-r--r--tests/auto/qmltest/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/tests/auto/qmltest/CMakeLists.txt b/tests/auto/qmltest/CMakeLists.txt
index 8ab433b4..3f891438 100644
--- a/tests/auto/qmltest/CMakeLists.txt
+++ b/tests/auto/qmltest/CMakeLists.txt
@@ -1,9 +1,18 @@
-qt_internal_add_test(tst_qmltest
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ *)
+list(APPEND test_data ${test_data_glob})
+
+qt_internal_add_test(tst_qmltest_datavis
QMLTEST
SOURCES
tst_qmltest.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
+ TESTDATA ${test_data}
)
set(qmltest_resource_files
@@ -11,7 +20,7 @@ set(qmltest_resource_files
"customtexture.jpg"
)
-qt_internal_add_resource(tst_qmltest "qmltest"
+qt_internal_add_resource(tst_qmltest_datavis "qmltest"
PREFIX
"/"
FILES