summaryrefslogtreecommitdiffstats
path: root/tests/manual/barstest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/barstest/CMakeLists.txt')
-rw-r--r--tests/manual/barstest/CMakeLists.txt32
1 files changed, 21 insertions, 11 deletions
diff --git a/tests/manual/barstest/CMakeLists.txt b/tests/manual/barstest/CMakeLists.txt
index 50c156e5..391b98aa 100644
--- a/tests/manual/barstest/CMakeLists.txt
+++ b/tests/manual/barstest/CMakeLists.txt
@@ -1,23 +1,33 @@
-qt_add_executable(barstest
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+qt_internal_add_manual_test(barstest
GUI
SOURCES
chart.cpp chart.h
+ sliderwrapper.cpp sliderwrapper.h
+ buttonwrapper.cpp buttonwrapper.h
custominputhandler.cpp custominputhandler.h
main.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Widgets
- Qt::DataVisualization
-)
+ NO_PCH_SOURCES
+ chart.cpp # undef QT_NO_FOREACH
+ )
+target_link_libraries(barstest PUBLIC
+ Qt::Gui
+ Qt::Widgets
+ Qt::DataVisualization
+ )
set(barstest_resource_files
"shuttle.obj"
"shuttle.png"
-)
+ )
-qt_add_resource(barstest "barstest"
+qt_internal_add_resource(barstest "barstest"
PREFIX
- "/"
+ "/"
FILES
- ${barstest_resource_files}
-)
+ ${barstest_resource_files}
+ )