summaryrefslogtreecommitdiffstats
path: root/tests/manual/qmlperf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qmlperf/CMakeLists.txt')
-rw-r--r--tests/manual/qmlperf/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/tests/manual/qmlperf/CMakeLists.txt b/tests/manual/qmlperf/CMakeLists.txt
index 141ba0c8..b2a90d5f 100644
--- a/tests/manual/qmlperf/CMakeLists.txt
+++ b/tests/manual/qmlperf/CMakeLists.txt
@@ -1,7 +1,7 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
qt_internal_add_manual_test(qmlperf
GUI
@@ -9,13 +9,18 @@ qt_internal_add_manual_test(qmlperf
datagenerator.cpp datagenerator.h
main.cpp
)
+
target_link_libraries(qmlperf PUBLIC
Qt::Gui
+ Qt::Qml
+ Qt::Quick
Qt::DataVisualization
)
set(qmlperf_resource_files
"qml/qmlperf/main.qml"
+ "qml/qmlperf/Tests.qml"
+ "qml/qmlperf/AutoTest.qml"
)
qt_internal_add_resource(qmlperf "qmlperf"