summaryrefslogtreecommitdiffstats
path: root/tests/manual/qmlperf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qmlperf/CMakeLists.txt')
-rw-r--r--tests/manual/qmlperf/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/manual/qmlperf/CMakeLists.txt b/tests/manual/qmlperf/CMakeLists.txt
new file mode 100644
index 00000000..666f279f
--- /dev/null
+++ b/tests/manual/qmlperf/CMakeLists.txt
@@ -0,0 +1,19 @@
+qt_add_executable(qmlperf
+ GUI
+ SOURCES
+ datagenerator.cpp datagenerator.h
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+set(qmlperf_resource_files
+ "qml/qmlperf/main.qml"
+)
+
+qt_add_resource(qmlperf "qmlperf"
+ PREFIX
+ "/"
+ FILES
+ ${qmlperf_resource_files}
+)