summaryrefslogtreecommitdiffstats
path: root/tests/manual/scattertest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/scattertest/CMakeLists.txt')
-rw-r--r--tests/manual/scattertest/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/manual/scattertest/CMakeLists.txt b/tests/manual/scattertest/CMakeLists.txt
new file mode 100644
index 00000000..89013c12
--- /dev/null
+++ b/tests/manual/scattertest/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+qt_internal_add_manual_test(scattertest
+ GUI
+ SOURCES
+ main.cpp
+ scatterchart.cpp scatterchart.h
+ NO_PCH_SOURCES
+ scatterchart.cpp # undef QT_NO_FOREACH
+ )
+target_link_libraries(scattertest PUBLIC
+ Qt::Gui
+ Qt::Widgets
+ Qt::DataVisualization
+ )