summaryrefslogtreecommitdiffstats
path: root/tests/manual/scattertest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/scattertest/CMakeLists.txt')
-rw-r--r--tests/manual/scattertest/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/manual/scattertest/CMakeLists.txt b/tests/manual/scattertest/CMakeLists.txt
index 00177653..89013c12 100644
--- a/tests/manual/scattertest/CMakeLists.txt
+++ b/tests/manual/scattertest/CMakeLists.txt
@@ -1,13 +1,15 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
qt_internal_add_manual_test(scattertest
GUI
SOURCES
main.cpp
scatterchart.cpp scatterchart.h
+ NO_PCH_SOURCES
+ scatterchart.cpp # undef QT_NO_FOREACH
)
target_link_libraries(scattertest PUBLIC
Qt::Gui