aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDennis Oberst <dennis.oberst@qt.io>2023-08-11 14:04:02 +0200
committerDennis Oberst <dennis.oberst@qt.io>2023-08-21 14:10:04 +0200
commit4f9687927da504c344a6e1805fe32f0b2d650d8e (patch)
tree70141bec85a818d8c24e02a94e6e8b23fe5fd91a /CMakeLists.txt
parent5cdd7fa66203808e3adcf48386fa0aea0d525889 (diff)
CMake: Add the Svg package to OPTIONAL_COMPONENTS
It is an optional dependency of the module and some examples and tests depend on it. Since this patch enables the Svg package on the CI, a previously unexecuted test has begun failing on the Android platform. This seems to be a known issue, thus add this particular test case to the BLACKLIST file. Change-Id: I46e00308a81189c80c7d788920908a884d05663d Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 005b06db63..e152cde949 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ project(QtDeclarative # special case
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets OpenGL OpenGLWidgets Sql Concurrent Test LanguageServerPrivate LinguistTools)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets OpenGL OpenGLWidgets Sql Concurrent Test LanguageServerPrivate LinguistTools Svg)
qt_internal_project_setup()
# Set up QT_HOST_PATH as an extra root path to look for the ShaderToolsTools package