aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 15:29:14 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 20:39:52 +0200
commit5a8b5f59e4335c5e230ee179b5f680c73a3607d3 (patch)
tree79c2e20314b572dae8581afd329c7ffc8cba0cde /CMakeLists.txt
parent38ac4b4ec2c08a6ea4ae693514e8c3520eb00c2a (diff)
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Pick-to: 6.2 Task-number: QTBUG-95018 Change-Id: Ic92ef51132db78f07891d3bab190078e9d3078b6 Reviewed-by: Kai Koehne <kai.koehne@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 450a18f0e0..b43ebd075d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qtdeclarative.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtDeclarative # special case