aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Eftevaag <oliver.eftevaag@qt.io>2023-05-24 17:44:41 +0200
committerOliver Eftevaag <oliver.eftevaag@qt.io>2023-05-26 10:03:00 +0200
commit064aa8127ca4be856f573c25d94d0cf86215a1c4 (patch)
tree3efe5d63f8c48cea7b819824c4a1f8e6b60c76a7 /examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
parentbd916dee64cf2bc710227fc2eb4231c68eaab626 (diff)
customitems examples: adhere to guidelines
They were in a pretty good state already. This patch simply makes some minor tweaks, based on our own guidelines for examples. The tweaks include, but are not limited to: - PRIVATE linkage - WIN32 and MACOSX_BUNDLE in qt_add_executable() - Remove unused #include - Use qsTr() - Remove warnings. Pick-to: 6.5 Change-Id: Ie4d50d4e2134b7b373bdf1ba38779d3052165286 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
Diffstat (limited to 'examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt b/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
index 72e7ebc574..6f3ed2f35c 100644
--- a/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
+++ b/examples/quick/customitems/painteditem/TextBalloon/CMakeLists.txt
@@ -14,7 +14,7 @@ qt_add_qml_module(qmltextballoon
textballoon.cpp textballoon.h
)
-target_link_libraries(qmltextballoon PUBLIC
+target_link_libraries(qmltextballoon PRIVATE
Qt6::Core
Qt6::Gui
Qt6::Qml