aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2023-06-14 06:30:33 +0800
committerMitch Curtis <mitch.curtis@qt.io>2023-08-23 15:40:21 +0800
commit842bb590be63be44f4761fdcd45f1c84e731fa3b (patch)
treeff30cf9ee5cad6cbc557950c285ce9315f265c84 /examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt
parent0ebd825d1077f51ad6cc5c15913e265aadb0550c (diff)
Fix attachedstyleproperties example installation
Make sure that libMyStyle.so, libMyStyleplugin.so, and the qmldir are installed. Fixes: QTBUG-114482 Pick-to: 6.5 6.6 Change-Id: I19b182f9957cc138171f0cb69eb25a42b7bf9b37 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt b/examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt
index f57aacdd41..1448b2d8bb 100644
--- a/examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt
+++ b/examples/quickcontrols/attachedstyleproperties/MyStyle/CMakeLists.txt
@@ -37,9 +37,12 @@ target_link_libraries(MyStyle PRIVATE
install(TARGETS MyStyle
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}/MyStyle"
)
+install(TARGETS MyStyleplugin
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}/MyStyle"
+)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qmldir
- DESTINATION "${INSTALL_EXAMPLEDIR}"
+ DESTINATION "${INSTALL_EXAMPLEDIR}/MyStyle"
)