aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2022-12-08 18:28:40 +0100
committerAmir Masoud Abdol <amir.abdol@qt.io>2023-02-01 23:39:19 +0100
commitec452fc6e87e82d135d7ef782d5c811583d5c433 (patch)
treed23a91de87691375298ee23435fc4bd1f21a3475 /examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt
parenta6d9312c99d6f80cbea7538276d2890d0cc4c760 (diff)
qt_add_qml_module: Make usage of AUTO_RESOURCE_PREFIX a policy
Writing AUTO_RESOURCE_PREFIX in every qt_add_qml_module call seems rather pointless. In addition: - Add documentation for QTP0001. - Adjust some of the examples to use QTP0001 policy. - Improved the error message. Pick-to: 6.5 Task-number: QTBUG-96233 Change-Id: I6e19a491acba97493893bf1953fca3462296c1ea Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Leena Miettinen <riitta-leena.miettinen@qt.io>
Diffstat (limited to 'examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt b/examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt
index c26fe1416b..cc56b319e7 100644
--- a/examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt
+++ b/examples/quickcontrols/chattutorial/chapter4/CMakeLists.txt
@@ -28,7 +28,7 @@ target_link_libraries(chattutorial-chapter4 PRIVATE
Qt::Sql
)
-# Resources:
+qt_policy(SET QTP0001 NEW)
qt_add_qml_module(chattutorial-chapter4
URI chapter4
QML_FILES