aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/testlib
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:19:01 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 18:10:53 +0200
commitcd7bd71d08f1c21648756d0a9fd501ce37a8cc0c (patch)
tree3aff5704f45b29623a5fbfeb55c9269f9170b809 /src/imports/testlib
parent221b2789dbc64520c97bf39a7d8465780c6fddfc (diff)
CMake: Fix qml module version to use the repo project version
Use PROJECT_VERSION instead of CMAKE_PROJECT_VERSION, so that the repo project version is used in a top-level build, rather than the version of the qt5 project. Pick-to: 6.1 6.0 Task-number: QTBUG-92861 Change-Id: I5a7a09baf81353558e512800746ac24e8e8b9a47 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/testlib')
-rw-r--r--src/imports/testlib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index 593b8c772c..fe70dd8a29 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -6,7 +6,7 @@
qt_internal_add_qml_module(qmltestplugin
URI "QtTest"
- VERSION "${CMAKE_PROJECT_VERSION}"
+ VERSION "${PROJECT_VERSION}"
CLASS_NAME QTestQmlModule
DEPENDENCIES
QtQuick.Window/2.0