aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/animation/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-06-29 15:27:51 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-11-02 16:32:25 +0100
commit250d6269e9f60021d88a574d04941ab342afb632 (patch)
treeb2630f309c5e94384b739e15d8c6a69e2e137101 /src/labs/animation/CMakeLists.txt
parent6b4d3613326b38bc05c813c449b31affd9c3795a (diff)
Migrate to autogenerated cpp exports
Replace the hardcoded cpp exports with a generated one where it's applicable. Task-number: QTBUG-90492 Change-Id: I4af021bf828e05c8d6f3f975befd3b6b2cf63462 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/labs/animation/CMakeLists.txt')
-rw-r--r--src/labs/animation/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/labs/animation/CMakeLists.txt b/src/labs/animation/CMakeLists.txt
index 88e756f3a6..c733a6db23 100644
--- a/src/labs/animation/CMakeLists.txt
+++ b/src/labs/animation/CMakeLists.txt
@@ -11,4 +11,6 @@ qt_internal_add_qml_module(LabsAnimation
PUBLIC_LIBRARIES
Qt::QmlPrivate
Qt::QuickPrivate
+ GENERATE_CPP_EXPORTS
+ GENERATE_PRIVATE_CPP_EXPORTS
)