aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2022-04-28 11:03:09 +0200
committerAndrei Golubev <andrei.golubev@qt.io>2022-06-02 10:07:39 +0200
commit26179e693717535eeff2e7b2a6ee99dc02dcd8f9 (patch)
treed546e470e6047165bff96209e5a8d913bc3abf75 /src/qml/CMakeLists.txt
parentb85ac05e4ab3ef356ef59f6c57f44855edf15c5c (diff)
Address extension types in qmltc
Whenever working with properties (reading, writing, aliasing, etc.) of the type that has extensions, prefer the same-named properties from extension objects over type-owned properties (this is the internal QML mechanism) To achieve that, we need to query the extension object: * for Q_GADGETs use a dummy model of assuming we can cast the object to the extension type and use that * for Q_OBJECTs use a qmlExtendedObject() with additional logic of figuring out which extension should be picked in each specific case Create QQmlProxyMetaObject via a custom dynamic meta object API for qmltc-compiled objects that are derived from base types with extensions Task-number: QTBUG-91956 Change-Id: I5e783768ae2abdb9dddf894de7e79960244352bd Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index a10228f3bb..b741596b82 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -347,7 +347,9 @@ qt_internal_add_qml_module(Qml
types/qqmlbind.cpp types/qqmlbind_p.h
types/qqmlconnections.cpp types/qqmlconnections_p.h
util/qqmlpropertymap.cpp util/qqmlpropertymap.h
+
qmltc/qqmltcobjectcreationhelper_p.h
+ qmltc/qqmltcobjectcreationhelper.cpp
qmltc/supportlibrary/qqmlcppbinding_p.h
qmltc/supportlibrary/qqmlcppbinding.cpp
qmltc/supportlibrary/qqmlcpponassignment_p.h