aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2023-11-13 10:54:32 +0100
committerUlf Hermann <ulf.hermann@qt.io>2023-11-17 07:43:47 +0100
commit364abd88174fe8dc2c24305021c76df66fed7226 (patch)
tree0895e9cb9dbadd14eb9e8b75a3a9de6e8ad69a5d /src/qml/CMakeLists.txt
parentec9612768fa53dd7a203f69873718f345d6c1219 (diff)
QtQml: Have QtQml.Base formally import QML
This way we don't have to register QtObject and Component twice. The QML_NAMED_ELEMENT etc. will return when we make the builtins a proper module. The imperative registration is a stop gap measure. Task-number: QTBUG-101143 Change-Id: I726aa77156b31aa624ac44d30e180ace6cb9d790 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index c907f2b17b..531fb95701 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -39,6 +39,8 @@ qt_internal_add_qml_module(Qml
PLUGIN_TARGET qmlplugin
CLASS_NAME QtQmlPlugin
PLUGIN_TYPES qmltooling
+ IMPORTS
+ QML/1.0
SOURCES
../3rdparty/masm/assembler/ARM64Assembler.h
../3rdparty/masm/assembler/ARMv7Assembler.cpp ../3rdparty/masm/assembler/ARMv7Assembler.h